Android P лишится поддержки старых приложений

0
381

Выпущенная в начале месяца первая бета Android P включает множество полезных нововведений вроде навигации в помещениях через Wi-Fi, нативной поддержки двойных камер, анализа мобильных сетей и других, но не обошлось и без недостатков. Как оказалось, новая ОС от Google не поддерживает старые Android-приложения.

Ранее Google заявила, что следующие версии Android будут блокировать приложения, не использующие последние API, но до сих пор с этим у разработчиков не было никаких проблем. Начиная с Android P, в операционной системе появился инструмент «MIN_SUPPORTED_TARGET_SDK_INT», указывающий на минимально поддерживаемый уровень API. Для Android P он установлен на v17, что соответствует Android 4.2.

Таким образом, на устройствах с Android P не работают приложения, написанные под Android 4.1 и более ранние версии операционной системы. При попытке их запуска вы увидите соответствующее уведомление об ошибке:

Google хочет, чтобы Android-приложения поддерживали все новейшие функции, например, режим экономии энергии Doze. Это должно положительно сказаться на производительности, автономности и безопасности. Правда, вместе с этим у пользователей перестанут работать приложения, которые больше не обновляются.
источник

Оставьте комментарий

Please enter your comment!
Please enter your name here

− 2 = 6